Composer在phpstudy环境下安装及使用教程 [基础教程]

作者:代号黑鹰 发布于:2016-07-08 浏览:1529次 收藏

场景

前端日子群里有个人问了composerSLL用不了的问题,我开始不在意,以为用不到。

今天我碰到了。弄得我一身狗血!(composer+phpStudy)

参考资料:https://segmentfault.com/q/1010000000458019

Step 1 安装composer

step1.png

我这里选择的是5.4版本的php(这里非常重要)

然后一直点击下一步完成安装。好了。

Step 2 开启ssl

首先查看你的phpStudy当前使用的版本(很重要
step2.png

我这里是5.3的(我前面安装composer用的是5.4的别忘了)

然后把下图的红框里面的东西(勾上)

step3.png

上面两个红色的两点没有注意的话,就会出现下面的错误!

step4.png

然后开心的去安装我的yii2扩展了(云片短信)

composer require dcb9/yii2-yunpian

安装到这里结束了么(错!)看下面

step5.png

在这之前要安装git,哪就安装一个吧(出现上面的原因是之前我安装扩展时用七牛做实验没有github的touken我中断了安装-之后安装我的短信扩展时也把他安装上了---七牛安装失败了!原因吗上图)。

最好用git bash进行composer安装yii扩展—上面的(git不是内部命令)错误就没了

step6.png

最后提醒:

github的邮箱验证国内邮箱收不到,加入白名单也收不到--QQ貌似可以,用雅虎吧

(要邮箱验证才能在里面设置你的tonken)


如果文章对您有所帮助,希望继续支持我们,您的支持是我们最大的动力 ¥打赏
标签: composer phpStudy
声明:文章内容由作者原创或整理,未经允许,不得转载!
您需要登录后才可以评论。登录 | 立即注册